Pageviews

Follow Ritesh Maddala Blogs - Join the Fan Club Today and Keep Learning

Wednesday, October 16, 2013

ObAccessClient.lst does not contain a client id - ACCESS_GATE FATAL 0x00001824

Hi,

Problem Description :

When A new Webgate agent is registered with OAM, sometimes due to some mis-configuration it the OHS servers throws some common exception. Today I got a very uncommon exception in OHS - Webgate - OAM configuration. Below is the stack trace came in :
------------------------------------------------------------------------------------------------------------
Message from syslogd@ at Wed Oct 16 10:19:05 2013 ...
mmvhsgbobis001a Oblix: 2013/10/16@10:19:05.07603      
3716    3765    ACCESS_GATE     FATAL   0x00001520    
/ade/aime_ngamac_497961/ngamac/src/palantir/webgate2/src/apache2entry_web_gate.cpp:589
"Exception thrown during WebGate initialization"

Message from syslogd@ at Wed Oct 16 10:19:05 2013 ...
mmvhsgbobis001a Oblix: 2013/10/16@10:19:05.07618      
3716    3765    ACCESS_GATE     FATAL   0x00001824    
/ade/aime_ngamac_497961/ngamac/src/palantir/webgate2/src/apache2entry_web_gate.cpp:590
 "ObAccessClient.lst does not contain a client id."      raw_code^213

------------------------------------------------------------------------------------------------------------

Message from syslogd@ at Wed Oct 16 10:46:35 2013 ...
mmvhsgbobis001a Oblix: 2013/10/16@10:46:35.09020    
 4728    4733    ACCESS_GATE     FATAL   0x00001520  
 /ade/aime_ngamac_497961/ngamac/src/palantir/webgate2/src/apache2entry_web_gate.cpp:589
  "Exception thrown during WebGate initialization"

Message from syslogd@ at Wed Oct 16 10:46:35 2013 ...
mmvhsgbobis001a Oblix: 2013/10/16@10:46:35.09035    
 4728    4733    ACCESS_GATE     FATAL   0x0000182A  
 /ade/aime_ngamac_497961/ngamac/src/palantir/webgate2/src/apache2entry_web_gate.cpp:590
"An internal ObError exception was caught."     raw_code^224

------------------------------------------------------------------------------------------------------------

Solution for Above Error:
------------------------------
Check "ObAccessClient.xml file in 
MW_HOME/ohs/instances/instance1/config/OHS/ohs1/webgate/config

If anything is looking inappropriate, just once more copy the artifacts from OAM_RREG_HOME/output/Agent_Name/ObAccessClient.xml  to this location.
(In My case I have registered the Agents using RREG - OAM remote Registration Tool).

If that doesn't work, you have to delete the present Agent from OAM and  re-register the Agent to create the new Artifacts (cwallet.sso and ObaccessClient.xml). Copy the new Artifacts to MW_HOME/ohs/instances/instance1/config/OHS/ohs1/webgate/config





9 comments:

  1. Hi ritesh.
    I tried copying ObAccessClient.xml twice and reregistering agent but still I am getting same issue.
    Error message:
    Message from syslogd@ at Thu Dec 12 07:22:29 2013 ...
    slc00iyv Oblix: 2013/12/12@07:22:29.08480 21749 21804 ACCESS_GATE FATAL 0x00001520 "Exception thrown during WebGate initialization"

    Message from syslogd@ at Thu Dec 12 07:22:29 2013 ...
    slc00iyv Oblix: 2013/12/12@07:22:29.08492 21749 21804 ACCESS_GATE FATAL 0x00001824 "ObAccessClient.lst does not contain a client id." raw_code^213

    ReplyDelete
    Replies
    1. Hi,

      Let's do this work around first.

      Please stop all servers and try to restart access manager server and then start OHS server. OHS sometimes doesn't pick Access server after its first time registration.


      Hope this will help you or else we will figure out your problem after the above work around. 

      Regards
      Ritesh

      Delete
    2. Thanks, this definitely helped us resolved similar problem

      Delete
  2. I'm getting the similar error but my problem is that when we register a mod osso agent, no xml file is generated. Any ideas?

    ReplyDelete
    Replies
    1. Have you checked the logs ... what errors you are getting ??
      Share it to narrow down the problem.

      Delete
  3. this might not be ideal but it worked i gave 777 recursively for all the installed directories and it worked, i dont see these error message again.

    ReplyDelete
  4. thanks Rithesh and naveen. I have followed the both guidelines, it worked for me. Copied the files as mention and set 777 permission to all directories recursively in apps tier and web tier. Then restart the opmn.

    ] $MW_HOME/Oracle_WT1/instances/instance1/bin/./opmnctl startall

    ReplyDelete

Follow Ritesh Maddala Blogs - Join the Fan Club Today and Keep Learning

Follow Me

Java Application Examples

Java Application / Software Development

Follow by Email